NVGate Waterfall

From OROS Wiki
Jump to navigation Jump to search

The Waterfall module is used to stack data from NVGate plug-ins, such as Spectra, 1/n Octave, RPM, DC, or any scalar data values into one graph. Data is displayed as slices that are synchronized and can be sorted by references (time, RPMs or DC channel). We can display 3D data or profile (2D).

Overview

The following scheme describes the waterfall slices collection behavior. When selected event (trigger) occurs, the latest computed data from each associated plug-in are collected into the current slice. Then data can be displayed into 2D (for scalar) and 3D graph in function of each reference.

Waterfall monitor 03.png

Stackable results

  3D 2D (profiles)
FFT * Triggered block
* Weighted block
* Inst. Spectrum
* Average Spectrum
* Inst. Cross Spectrum
* Average Cross Spectrum
* FRF H1
* FRF H2
* Coherence
* Inst. Zoom Spectrum
* Average Zoom Spectrum
* Zoom Cross Spectrum
* Zoom Average Cross
* Zoom FRF
* Zoom Coherence
* Overall Power

* Order x


Sync. Order * Triggered block
* Weighted block
* Order Inst. Spectrum
* Order Average Spectrum
* Order x

* Overall Power
1/n Octave * 1/n Octave
* Average results: - AvNoct
- MinOct
- MaxOct
* Overall level: OvrLin

* Overall Weighted level: OvrWgt
Overall acoustic   - Lxypeak
- Lxy inst
* Lxy eq 1/8s
* Lxy eq 1s
* Lxy eq t
X = Applied weighting (A or C), in case of Z selection (no weighting) X is not displayed.
Y = Applied time filter (None, Fast, Slow or Impulse), If none is selected (no time filtering) Y is not displayed.
t = Short time integration duration. T
Tachometer   * Tach Angular Speed (ref)
* Virtual Angular Speed (ref)
* Ext Tach Angular speed (ref)
* DC Tach speed (ref)
* Combined tach speed (ref)
* Fractionnal tach (speed)
Front end  
  • DC (ref)
  • CAN (ref)
Monitor  
  • Monitor DC
  • Monitor RMS
  • Monitor Peak
  • Monitor Peak-Peak
  • Monitor Crest-Factor
  • Monitor Skew
  • Monitor Ktsis
  • Monitor Max
  • Monitor Min
Time domain  
  • DC
  • RMS
  • Max
  • Min
  • Peak
  • Peak-Peak
  • Crest-Factor
  • Ktsis
N.A.  
  • Time (ref) always selected
  • Slice (ref) always selected

Computation SPUs

Unlike other plug-in, the memory of the waterfall depend on the capacity of the PC and others applications running on it. The depth of the waterfall is function of the free memory of your PC, and is limited to around 3 millions samples per DSP.

Tutorial

Waterfall connection

This section will show the different ways to add results into the waterfall.

From the Show Result window

The Show Results window is the most common way of adding a result in the waterfall. Here I will show you how to simply display a waterfall of the average spectrum for an acceleration input.

First, open the Show Result window, go in the FFT 1 tab, and reach the Waterfall section :

GoToResult Waterfall.png


Then, select Avg. Spectrum and the fist input. Finally click on DisplayButton.png to display the waterfall :

GTR Display Waterfall.png


The 3D view of the waterfall is displayed.

For more detail please see NVGate Software overview.

See also the RT60 with interrupted source tutorial video, where this method is used :


From the graph window

This method will allow you to add the result from a currently displayed graph into the waterfall. This will work with any result of NVGate compatible with the waterfall. As previously, we will add the Average spectrum all the channels into the waterfall.

First of all, right-click on the grey border of the graph and go in the Add to Waterfall section :

WTF RightClick.png


  • All Trace will add all of the traces in the graph into the waterfall
  • Active Trace will only add the active trace of the graph into the waterfall.


Here, we will select All Trace, as we want to add all the channels of the FFT plug-in.

WTF RgtClick AllTrace.png


All the traces have been added, and the waterfall can be displayed from the Add/Remove windows menu of theDisplay/Graphs tab of the Ribbon :

DisplayWTF.png


The 3D view of the waterfall is now displayed in the current layout.

From the waterfall plug-in menu

Finally, results can be add into the waterfall directly from the waterfall menu. To do so, go into the Analyses tab of the NVGate ribbon, and click on WTF AddRemove.png in the waterfall section :

WTF Ribbon.png


This will open the waterfall menu. Here, select the result (Avg. Spectrum), the channels you want to add (in that example, all the channels), and finally click on the green arrow WTF Arrow.png :

WTF AddResults.png


Click on OK, the results have been added to the waterfall. You can now display it with the method described in the previous section.

Waterfall profile display

We saw in the previous section that a waterfall collect all-along the acquisition results from NVGate plug-ins, like a spectrum, in a single graph. Now if we connect to the waterfall a plug-in that is not delivering a complete trace, but a single scalar value, the collection during the acquisition off all these successive scalar values will result in a simple curve in the waterfall. This is what is called a Profile in NVGate.

A profile can be used to plot trend over the time for DC inputs, Overall RMS level and Bode plots of Orders over the RPM value of the shaft.

In this section, I will show you how to display a profile of the Overall RMS level on a channel connected the the FFT 1 plug-in. I will present the three same methods presented in the previous section.

From the Show Result window

The Show Results window is the most common way of adding a result in the waterfall. Here I will show you how to simply display a Profile of the overall level for an acceleration input.

First, open the Show Result window, go in the FFT 1 tab, and reach the Profile section :

Profile ShowResults.png


Then, select Order & Overall and the fist input. In the Tracked order section, select Overall. Finally click on DisplayButton.png to display the waterfall :

Profile ConfigShowResult.png


The profile window is now displayed in the current layout, and you can run the acquisition. However, you may need to adapt the depth of the waterfall to contain all the data. To do so, double-click on the dark grey border of the graph, in the FFT menu, select Waterfall. In the Mode tab of the waterfall, modify the Number parameter :

Addapt Depth.png


To change the profile reference , right click on the graph : select reference.

Change reference.png


For more detail please see NVGate Software overview, and the following sections.

From the graph window

As we did for the standard waterfall, we will now see how to add a scalar value in the waterfall to create a profile directly from the result window.

Here, we have displayed the Overall level an acceleration input from the FFT plug-in :

FFT Overall scalar.png


Right_click on the border of the window and go in the Add to waterfall section. There is only one trace in the window here, so only Active trace is available. :

Scalar RightClick.png


After clicking on Active Trace, the Overall Level is added in the waterfall. We will now use the same method to display the profile. go in the Add/Remove windows menu of theDisplay/Graphs tab of the Ribbon :

Display WTF Profile.png


The profile is now displayed in the current layout. As previously, you may need to adapt the depth of the profile.

From the waterfall plug-in menu

As for other results, scalar results can be add into the waterfall directly from the waterfall menu. To do so, go into the Analyses tab of the NVGate ribbon, and click on WTF AddRemove.png in the waterfall section :

WTF Ribbon.png


This will open the waterfall menu. Here, select the result (Order & Overall), the channels you want to add , and finally click on the green arrow WTF Arrow.png :

WTF Menu Profile.png


After clicking on WTF Arrow.png, the trace is added in the References and Profiles section :

Profile WTF Menu Final.png


Click on OK, the results have been added to the waterfall. You can now display it with the method described in the previous section.

Waterfall Display

The Waterfall window offers a wide range of operation in order to go further in your measurement. It is possible to display XY and YZ sections as well as the extraction section. From the Display/Graph tab and the 3D group, this group provides general purpose tools about the Waterfall 3D graphs.

Reports Tools Ribbons 470.png

The first button corresponds to displayed graphs. Each Waterfall windows may displays up to 4 different graphs. It is a multi-action button.


The Waterfall window is composed of 4 main areas:

  • Reports Tools Ribbons 471.png3D only: Shows the 3D graph only. This graph can be a 3D plot or a color map.
  • Reports Tools Ribbons 472.pngX/Y only: Shows the X/Y extraction graph only. This graph contains the spectra at the cursor position and the X/Y sections.
  • Reports Tools Ribbons 473.pngY/Z only: Shows the Y/Z extraction graph only. This graph contains the time (or ref) profile at the cursor position and the Y/Z sections.
  • Reports Tools Ribbons 474.png Extraction only: Shows the Order/frequency extraction graph only. This graph contains the order/frequency profile at the cursor position and the extraction sections.
  • Reports Tools Ribbons 475.png All graphs: Shows all the graphs in a matrix.
Usersmanual 170.png

Cursors give information about the displayed Waterfall trace (current X, Y and Z coordinates are available from the Infotrace).

Move the cursors either by using the drag & drop in the 3D view or by using the arrow pad of the keyboard (the cursor mode Usersmanual 171.png must be selected).

Tip: Move the mouse over the cross in the middle of the window and click in order to resize manually the graph window.

3D waterfall graph or ColorSpectrum view

Usersmanual 172.png
  • Reports Tools Ribbons 477.png3D perspective: Plot the spectra (or trigger blocks) in a true 3D space, taking in account the perspective. The global orientation of the gathered spectra can be changed using the rotate button. This type of view allows looking at the waterfall from any side
  • Reports Tools Ribbons 476.png3D Isometric: Plot the spectra (or trigger blocks) along a Z axis with the same scale whatever is the position. The Z axis angle is modified by the rotate button.

3D Isometric

Usersmanual 173.png
  • Reports Tools Ribbons 480.png Rotate: Toggle the rotating mode. Allows rotating the 3D graphs with the mouse when enabled. Disabling this item return the mouse to the previous mode.
  • Reports Tools Ribbons 479.pngFrequency/time color map: Plot the spectra (or trigger blocks) on 2D map with the color representing the point amplitude. This plot show the Frequency (Y) Vs Time (X) arrangement
  • Reports Tools Ribbons 478.pngTime/frequency color map: Plot the spectra (or trigger blocks) on 2D map with the color representing the point amplitude. This plot show the Time (Y) Vs frequency (X) arrangement

Freq/Time colormap

Usersmanual 174.png

References

The waterfall data are arranged in accordance to the active reference. A reference is a scalar value (RPM, DC level, RMS, Parametric input) stored with the waterfall data.

Right click on the grey part of the graph.to select the active reference.

Usersmanual 40.png

The displayed data are then sorted regarding the reference value.

Usersmanual 175.png

A threshold is available on a waterfall by pressing the ’y’ button (or ’ctrl y’ for more precision).

Display Graphs Traces 76.png


Sections

  • Reports Tools Ribbons 481.png Add section: Add a copy of the cursor location in each of the 3 extraction graph

Waterfall display provides extraction of section from the 3D space

Display Graphs Traces 118.png

These sections are linked with cursors of the 3D view:

  • Fig1: for a fixed value of the X-axis of the 3D view,
  • Fig2: For a fixed value of the reference
  • Fig3: for a fixed value of the order (follow the evolution of an order) or frequency for order spectra waterfall.

During the acquisition, an autoscale is available on the z-axis (reference) if ’z Adjust’ is active.

Display Graphs Traces 119.png
  • Add section: Creates a new section at the current position of the cursor. The extraction section is created only if a tach has been selected in the Waterfall.
  • Select YZ section: Selects the active trace in the YZ graph. Useful to get the value of the cursor for this section
  • Select XY section: Selects the active trace in the XY graph. Useful to get the value of the cursor for this section
  • Select extraction section: Selects the active trace in the extraction graph. Useful to get the value of the cursor for this section


The ’Select Tacho’ mode allows tracking an order in function of the selected tachometer. The extraction order could be done in function of the selected tacho. 4 Graphs are available for the windows allowing tracking different results:

  • 3D view: you can select by right-clicking on it an isometric view, a perspective view, a freq/time colormap or a time/freq colormap (useful to track orders). The 3D view is the default view.
  • YZ section,
  • Order extraction (only available if a tachometer is active).
Display Graphs Traces 120.png

The sections are displayed in these 2D views. The sections can be managed in the section manager windows. In the section manager, add section made a copy of each cursor (Frequency, Reference, Order) in all displayed windows. These memorized traces could be added to result by the ’add to result selection.The waterfall sections can be saved as independent results (spectra, reference profiles, extracted profiles). The selection is achieved using the "Add to result selection" entry from the waterfall window contextual menu.


Display Graphs Traces 121.png

After being saved, the sections became independent results, reducing the amount of saved data when you are focusing only on extracted data.

Section manager

You can fine tune the section parameters by using the section manager available by right clicking on the Waterfall window. For example, you want to visualize the first order.

  • Reports Tools Ribbons 482.png Section manager: Open the waterfall section manager.

or, right click in the grey part of the graph and select Section manager.

Usersmanual 176.png
  • Section manager: This dialog box is used to create and modify sections.

To modify a section, select the desired type and the desired section then modify the Section properties and click "Apply". To create a new section, Select the type, set the desired properties and click "Add". To remove a section, select the desired type and the desired section, then click "Remove".

Display Graphs Traces 01.pngDisplay Graphs Traces 69.pngDisplay Graphs Traces 70.png

  • Section properties: The XPos, ZPos, Freq or Order defines the position of the section in the Waterfall. When the "Advanced" box is checked, it defines the center of the band. The width is used when the "Advanced" box is checked. It defines the bandwidth.

The advanced sections are:

Type Sections Type of result Description
Power YZ, Order and Frequency extraction sections Frequency, order and octave spectra Calculates the power within the band
Peak YZ, Order and Frequency extraction sections Frequency, order and octave spectra Detects the highest value
RMS YZ sections Triggered and resampled block Calculates the RMS value within the band
Average YZ sections Triggered and resampled block Calculates the average value within the band
Min YZ sections Triggered and resampled block Detects the minimum value within the band
Max YZ sections Triggered and resampled block Detects the maximum value within the band


  • Z-Operator:


This Operator is available on XY extraction view and 3 operators are available: Min, Max and Arithmetic Average.

Display Graphs Traces 71.png
  • Order Extraction:
Display Graphs Traces 02.png
     
Display Graphs Traces 72.png

This Operator take data spectrum by spectrum, for each spectrum there is a determination of the max value and of the corresponding order. Using this operator it is possible to detect on which orders it is useful to work. Note: The Max Order cannot be saved in result (not available in the ’Add to result selection’).

Save results

This section gets you to select and save the Waterfall results.

Right click on the Waterfall window and select Add to result selection. A window that allows you to select the results to be saved is displayed:

  • The entire Waterfall results
  • The extraction section (in this case it is the order 2 section) independently
  • The XY section independently
  • The YZ section independently
Usersmanual 13.png

Click on OK.

Usersmanual 12.png

Click on: Measurement/Save/ Save Measurement, your results selection will be automatically saved:

Usersmanual 178.png

Settings

Glossary

This section will explain specific vocabulary of the Waterfall.

  • Slice: this represents one acquisition of the Waterfall. A slice is a set of scalar and spectrum data acquired at the same time. The Waterfall is a stack slices.
  • Depth: this is the maximum number of slices you can acquire on the Waterfall.
  • Section: section at the current position of the cursor. The extraction section is created only if a tach has been selected in the Waterfall (see chapter 2 Display, Waterfall window menu).
  • Reference: A scalar collected by the waterfall acquisition that can put in order the slices. The reference corresponds to the X-axis of the profiles and the Z-axis of the 3D graphs.
  • Profiles or 2D Results: profiles of a scalar evolution in function of time or any reference associated with the waterfall
  • Results 3D: spectra collected by the waterfall acquisition putted in order by a reference. These types of results are displayed in 3D graphs (3D, isometric or color-spectrogram).
Channel

The different channels are available by putting selected inputs in the plug-in.

It contains the results to be picked up by the Waterfall.

The following window lets you select for each analysis plug-in, the channel related to the result.

Waterfall monitor 04.png
  • Source: In the ASB the channels are different from other ASB channels, the source of channel 1 and following are the results. The source of channel 64 and previous ones are the references. By default the time reference is always associated with a result source.
Waterfall monitor 05.png
Trigger

Contains the settings related to triggering events and how to start and stop signal computation.

  • Start: selects the event to start the waterfall acquisitions. This setting selects the event, which enable acquisition that is to say data collection does not operate while start event is no occurred. Any event can be chosen among the list of defined events. By default only the Free run and Manual events are available. Additional events can be defined in the "Event Definition" shared resource. The start time corresponds to the zero of the waterfall time scale. By default start is set to "free run" this allows waterfall acquisition to start immediately after run.
  • Stop: selects the event to stop the waterfall acquisitions. This setting selects the event, which ends acquisition that is to say data collection, does not operate after stop event occurred. Any event can be chosen among the list of defined events. By default only the Free run and Manual events are available. Additional events can be defined in the "Event Definition" shared resource.
  • Trigger: selects the event that trigs waterfall acquisitions. This setting selects the event which trig acquisitions that is to say a new data collection occur each time trigger event occurred. If trigger is set to periodic (period 20ms) the Waterfall acquisition will operate as fast as possible, this can hang user interface during acquisitions. The first time a source is selected for the Waterfall, if trigger = Periodic, then the event corresponding to the availability of the source results is assigned to the trigger. Ex: Setting FFT1 spectra into the waterfall plug-in will set Trigger to ’FFT1 result available’. By default the trigger is set to ’Periodic’ with a period of 20.
List of events Description
Manual This event occurs when the user requests a manual trigger.
Events from Event module see Event module
FFTx result available This event is in the list if a signal is connected to an FFTx channel source. This event occurs when an FFT measurement starts. This event is generated at each calculation of a new spectrum in exponential averaging and at the end of averaging in linear.
Oct result available This event is in the list if a signal is connected to an Octave channel source. This event occurs when an Octave measurement starts. This event is generated at each new spectrum calculated (every 256 samplings) for CBT, Fast, Slow, Impulse and exponential averaging. For the others averaging this event is generated at the end of averaging on t.
Order x result available This event is in the list if a signal is connected to an Order x channel source. This event occurs when an Order x measurement starts. This event is generated at each calculation of a new spectrum in exponential averaging and at the end of averaging in linear.
Overall acoustic result available This event is in the list if a signal is connected to an Overall acoustic channel source. This event occurs when an Overall acoustic measurement starts. This event is generated at each new spectrum calculated (every 256 samplings) for CBT, Fast, Slow, Impulse and exponential averaging. For the others averaging this event is generated at the end of averaging on t.
Periodic

This event simplifies the instrument setup by shortcutting periodic event activation. Selecting periodic for the trigger will make appears the period setting.


There is two ways to trigger the waterfall:

  • The analyzer is running, it keeps in memory last measurements. Then with the waterfall you can select some specific results (for example for rpm or time).
  • The plug-in triggering, at the end of each average the plug-in send an event. The plug-in put the rhythm into the waterfall. This mode is the default mode.
Mode

Contains the settings related to the Waterfall display mode.

  • Mode:

Off: the Waterfall is inactive. This mode is useful to check your signal and your settings before the analysis.

One shot: the Waterfall is active between ’start’ and ’stop’, there’s only one acquisition (for example: coast downs or run ups). The Waterfall ends on stop or when the number of slices is full.

Continuous: this mode memorizes the n last slices (selected number of slices) before the stop event. This mode is similar to the ’time to stop’ mode of the recorder. This mode is different from the monitoring; the continuous mode is storage of measurement (for example: detection of ultimate strain).

  • Number: the number of Waterfall slices (from 2 to 100 000). If the Waterfall trigger is a Delta RPM event, the "Event number" of this Delta RPM event is assigned to the number of Waterfall slices.

The waterfall depth is managed automatically, allowing the user to get the larger slices/points number depending on the current available physical memory on the PC running NVGate. This functionality protects waterfall or profiles acquisition from memory overloads. That means the depth of the Waterfall is a function of slices weight (which depend on the type of analysis).

Waterfall monitor 06.png

The area is fixed. If the slices weight are important, then the depth would be small.

The area is function of the free memory space available when you select to use the Waterfall. The memory space has to be exactly the same during all the measurement that means the measurement could hang if you start another application on your computer during the measure.

The acquisition/display and save memory usages are managed separately and are sequenced. It result a larger of data managed by the waterfall and secured acquisition.

NVGate takes advantage of 64bits PC memory (> 2 GB) for larger memory allocation for the Waterfall. As NVGate remains a 32-bit application, PC memory is not used above 4 GB.

The following table summarizes the evolutions of the waterfall depth (for a given configuration: 32 ch 3,201 lines and PC):

For example a waterfall of 32 ch 3,201 lines handles up to:

PC configuration Slices
XP 32 bit 2GB RAM 260
Win7 64 bit 4GB RAM 640


NB: In the stand-alone mode, the depth is limited (about 3 million samples per DSP) due to the analyzer memory size.

Notes:

- OVA: if the waterfall trigger selected were « OvA Leq result available », the slices number would depend on durations (average duration « T » and short duration « t ») from the sub module Average in Overall acoustic.

Average type Slices number
short Leq (t) T/t
short Leq 1/8s T/t
short Leq 1s T/t
Linear, with repeat = End Of Averaging T
Linear, with repeat != End Of Averaging Independent


- 1/N Octave: if the waterfall trigger selected were « Oct result available », the slices number would depend on durations (average duration « T » and short duration « t ») from the sub module Average in 1/N Octave.

Average type Slices number
Linear, with repeat = End Of Averaging T
Linear, with repeat != End Of Averaging Independent
Repeat T/t
Exponential Indepedent
Constant BT Independent
short Leq 1/8s T/t
short Leq 1s T/t
Fast Independent
Slow Independent
Impulse Independent


The on line display uses more power and could slow displays but acquisitions and analyses remain real-time.

Waterfall status

All statuses are available to add to the control panel

Waterfall monitor 07.png

Waterfall
Waterfall monitor 08.png

The current plug-in status is synthesized in a special progress-bar. This status bar is automatically displayed in the ’control panel’ when the plug-in is active (i.e. as soon as at least 1 input is connected to the Waterfall plug-in). This status is called ’Waterfall’ and it is available in the status ASB tree (see customize control panel).

This status displays the slice number acquired in the waterfall, the plug-in state (Run, Paused or Stop) and the real-time status.

The way the status bar is displayed, depends on the mode selected:

  • ’One shot’ mode: the progress bar is filled from left to right.
  • ’Continuous’ mode: the progress bar is filled from right to left with flashing until the end of the acquisition.
  • ’Off’ mode: the progress bar is empty with the text ’Off’ inside.

The color of the bar and of the writing let you know what happens during the acquisition:

  • Green background and white or black text: acquisition in real time.
  • Red background and white or black text: the current acquisition is not real time.
  • Green background and red text: the current acquisition is real time, but a previous acquisition was not real time.
Trigger State

The following scheme describes the different states of the measurement:

Waterfall monitor 09.png

By default the trigger state is on ’Stop’ and waiting for a ’Run’ (start or trigger). Then the state become ’Triggering’ and is waiting for a start event, the states become ’Block Triggering’ and is now waiting for a trigger event for being in the ’Running state.

The state is ’Stop’ after a stop event or at the end of averaging.

Count

This status displays the averaging count, that total number of slices already acquired.

Real-time

This status displays if the averaging is in real-time or not (i.e. the current block is analyzed or not). If the corresponding signal were not available at this time, the acquisition is not real-time. That means that the treatment is longer than the acquisition. There are three values for this state:

  • ’OK’: The acquisition is real-time.
  • ’No’: One previous acquisition was not real-time.
  • ’-’: The acquisition is currently not real-time.
% Block lost

During an acquisition, results are stocked on the analyzer DSP in a buffer storage (limited to 4 MSample per DSP). If the depth of the waterfall is larger than this, then the PC must empty this buffer storage during acquisition (then the PC can store more results). The DSP to PC transfer takes place as soon as the waterfall acquisition starts depending on connection status (stand alone, poor quality). This process continuously empties the DSP memory. A block is lost if the DSP to PC transfer is not able to get it before the DSP memory is full.

In ’one shot’ mode and for depth smaller than X the acquisition is preferred to the displaying, i.e. the display takes place at the end of acquisition

In ’continuous’ mode or for depth larger than X, the displaying is preferred to the acquisition, in order to quickly see any changes during the measurement, some blocks may be lost.

% Block transferred

This status displays the percentage of block that the PC could have recovered from the DSP buffer storage.

Note that: %Block lost + %Block transferred = 100%.