NVGate Software overview

From OROS Wiki
Jump to navigation Jump to search


Analyzer software architecture

Analyzer architecture page

Dataset management

See NVGate Dataset management page

Starting NVGate

Tutorial

This example will show you how to use the "GoToResult" of NVGate to quickly perform a complete measurement setup from the start of the software. We will use an OR36TW analyser and NVGate V12.10. We will also use a demonstration rotorkit made from a standard model building electric motor and a gearbox. We will analyse the vibrations of this kit with two 100mV/g accelerometer, connected to the inputs 1 and 2 of the frontend, and use a 2 pulse/revolution tachometer, connected to the Ext. Sync.1 input, to extract orders.

Here we will see how to simply use NVGate to record the raw data, displaying the FFT, and display the tracking of the two first orders of all the sensors used.

Starting the analyser and NVGate

First of all, connect your analyser to the computer and power it on. Then double-click on the NVGate Icon from your desktop. The connection dialog appears. Select operation mode (Connected, Office or multi-instruments).

Connection.png

Select the analyser and click on start.

The NVGate splash screen will automatically appears.

NVGateStartImg.png

At this stage, you can click on the cross NVGateStartCross.png to abort the opening of the software.

Open/create a project

NVGate will start and the Start dialog is proposed:

Usersmanual 103.png

Here we will create a new project :

NewProg.png


This window is also accessible from the NVGate Ribbon.

This will open the "New Project" definition window. Fill up the necessary properties and comment to describe the context of this project. Check the Load setup box and click on the Ok button.

FillingNewProj.png


Load the configuration

This will open the Load setup window. This window allows you to load the configuration from a pre-saved model, a previous measurement, create a new setup or opening a signal for post-analysis. Here we want to setup a new configuration, we will select New On-Line :

SelectNesConfig.png
Select the inputs

Once you click Load, the input setup window appears :

InputEmpty.png


This window can be called anytime from the GoToResult. See Input selection for the detail of the parameters.

As we use 2 accelerometers, select check the "Acceleration" boxes for inputs 1 and 2, and select the appropriate sensors in the "Transducer" column for each inputs. If you don't see your specific sensors, please fill your transducer database.

AddInput.png


To add the inputs into the recorder, check the Record signals box :

CheckRecorder.png


By doing this, any inputs (even if added later) will automatically be connected to the recorder plug-in. This box is also available from the NVGate Ribbon.

Edit the Sampling Rate

The sampling rate is the rate to which the signals will be sampled by the analyzer. This will define the maximum frequency that can be analyzed during the online analysis or in post-analysis on the recorded signals. However, a higher sampling rate will need more computational power. You may choose a sampling rate that is twice the highest frequency you want to analyze.

To edit the sample rate, go in the Measurement tab of the NVGate ribbon.

SamplingRate.png


Here we have a 25,6kS/sec that allow us to analyze the data up to 10kHz.

Setup the analysis

Once the inputs are correctly declared, click on Results to setup the analysis :

ClickOnResults.png


This will open the Results window :

ResultWindow.png


This window can be called anytime from the GoToResult icons. See the Show result section for detail about this window.

Displaying the FFT analysis

We will now display the average spectrum for the two inputs :

AddingFFT.png


Once you selected the result you want to display, click on DisplayButton.png to display the graph in the current layout.
Make sure you checked the box Save displayed results to save the result at the end of the measurement.

The FFT graph window now appear in the current layout :

FFTDisplayWindow.png

.

Setting up the FFT analysis

We can now setup the FFT to optimise the analysis. To access to the setup parameters, click on settings in the Show result window :

SettingFFT.png


Here, the maximum speed of the motor is 2000RPM. That make the first order at 2000/60 = 33Hz and the tenth order at 330Hz. In order to optimize the computation, we will then limit the FFT bandwidth to 5kHz, the overlap to 67% and the number of lines to 1601 to have a correct precision.

ModSettingFFT.png


You can then press OK to close this window. For details about the parameters, please visit the NVGate FFT Analyzer page.

Adding Order Profile

We can now setup and display the order profile. To do this, select the Sync. order 1 tab of the Result window.

SOAShowResult.png


Here, we want to display the first two orders profile for each input. To do so, select the profile tab, and select Order & Overall under Result and Acceleration (that will select the 2 acceleration channels) under input. To track the 2 first orders, you can simply enter 1 and 2 under the Tracked Order section.

Finally click on DisplayButton.pngto display:

AddOrderProfile.png


The profile graph is now displayed on the current layout along with the FFT spectrum graph :

Complete setup.png


We will now need to add and declare the tachometer. To do so, select Add : Ext. Sync. 1 under Tachometer :

AddTach1.png


And set the threshold, coupling and Pulse/rev as recommended for your sensor :

SetupTacho.png


Please visit the external sync tachometer page for more details.

Displaying the recorder

In order to have a complete view of the measurement, you can display the recording of the raw signals by clicking on View in the Measurement Tab of the NVGate Ribbon:

ViewRecording.png


You can then automatically re-arrange the windows in the layout with the Arrangement Option of the Display/Graph tab:

ArrangeWindow.png


The displaying of the result is now complete :

CompleteDisplay.png


Perfroming and saving the measurement

We will now perform the measurement during a run-up of the motor. To do so, put the motor at its lowest speed, start the acquisition by clicking on RunIcon.png, and then stop it with StopIcon.png once you reached the top speed. You will see the graph updating with the last result.

The saving measurement window will then be opened. You can fill it with the maximum of information to help ease archiving and the sharing of the data :

SaveMeasurement.png


The acquisition is now complete and the result are displayed :

Results.png


And you can find the saved data under the Project name in the Project Manager :

ResultsSaved.png


The red area represents the recorded temporal raw data, the green area the FFT results and the blue area the Order tracking results.

GoToResult

Available from both the bottom bar and Home\Start\Select Inputs this window allows selecting the inputs to be used and setups their acquisition.


Access to the GoToResult windows is continuously available from the NVGate bottom bar.

The 2 first buttons control the visibility of the corresponding windows Inputs selection and Show results. Click once to show the window, click again to hide it. The 3rd button only opens the Results overview.

These 3 buttons show the windows described below.

V11 release 08.png

Hide the window by clicking on its control button, closing the window (up-right red cross), clicking on the Results button to show the next window.

Step 1: Inputs selection
Usersmanual 26.png
Usage

The Inputs selection window allows access to the other items of the NVGate interface (ex: check ICP, Autorange, change sampling frequencies, graphs…) while it remains open.

Usersmanual 110.png

The actions in this window apply immediately to the analysis, there is no possible cancel. In the same way actions in other parts of NVGate are immediately reflected in this window.

This window manages dynamic inputs only. For using parametric, CAN or ext. synch inputs, one should use the acquisition tab of the ribbon.

Operations

The Inputs selection window allows activating and setting-up the dynamic inputs in a fast and smart way. Inputs are activated and set to a physical quantity when the corresponding check box is clicked.

Selection

This table allows selecting one or multiple cells in an Excel like mode, using mouse drag, keyboard arrows and SHIFT/CTRL keys. After editing, the focus is automatically set to the next cell for continuous operation with the keyboard:

Exit key Return Tab Left arrow Right arrow Up arrow Down arrow
Next cell Down Right Left Right Up Down
Edition

Editing a cell or a group of cells is direct, no need to double click, simply enter the values or initials for combo boxes. Hit the <Space> key to open the combo with the current selection. This allows using the keyboard only while setting cells in a column or a line.

Add physical quantities

The 3 basic physical quantities (Voltage, Acceleration and Acoustic pressure) used in noise and vibration are proposed as default. Changing one input physical quantity will add a new column with this physical quantity.

In addition to the basics and active physical quantity, the columns also show the physical quantities of deactivated inputs. This is useful to add default physical quantities to your models.

Transducers

The list of possible transducers is adjusted to the input physical quantity. Ex: if an input is set to acoustic pressure, only a microphones’ list is proposed.

Sampling & groups

The sampling setting is new. It defines the recording sampling and the analysis bandwidth for each group of inputs. The groups correspond to the inputs physical quantities. See the Autobandwidth chapter for more details

There are 2 samplings, High and Low. Each sampling can be adjusted from the table with Right click -> Change -> Select new sampling.

Changing the sampling of one input will apply to all input in the same group. For applying different samplings to inputs with same physical quantity, use the ASB.

Sampling settings are also available from the ribbon Measurement\Front-end\High Samp. and Low Samp. and from the Front-end Module in the Analysis Setting Browser.

Record signals

Check this box to ensure the recording of all active inputs. This includes the DC inputs (parametric), the Ext Sync. and the CAN ones.

Unchecking this box just set the recorder to off. The inputs remain set in the recorder. This is helpful to temporarily pause the inputs recording; especially on setup fine tuning.


Usersmanual 05.png

The Record signal is also available from the ribbon Measurement\Front-end\Records signal. And from the show results window.

All instances of this setting work in the same way. Wiith this method, the recorder signals are not automatically displayed.

A new button is available to monitor temporarily or continuously the signal: Measurement\Control\View recording. It opens the signal monitoring window on top of the current layout. In the case of this window is already open in another layout, it swaps to this layout.

Access to all

By default, the window shows only the basic settings. In order to get the full columns, flyover the right side of the table and click on the grayed arrow.

Usersmanual 111.png

Same with the left arrow to return to the basic view.

Post-analysis

Inputs selection window works on both on-line and post-analysis modes.

Step 2 Show results
Usersmanual 28.png
Call

Available from both the bottom bar or directly following the Inputs Selection window, this window allows displaying and saving results from activated inputs.

Hide the window by clicking on its control button closing the window (up-right red cross) or by clicking on its corresponding button in the NVGate bottom bar.

Usersmanual 112.png
Usage

The Show results window allows access to the other items of the NVGate interface (Add/Change layout, Setup tachometer…) while it remains open.

Usersmanual 30.png

The actions in this window apply immediately to the analysis, there is no cancel possible from this window. In the same way, actions in other parts of NVGate are immediately reflected in this window.

This window manages to connect and display result from FFTx, SOAx, OCT plug-ins only. For results from TDA and OVA, one should use the Acqusition\Inputs\Connect inputs button followed by the Display/Graphs\Windows\Add/Remove one from the ribbon.

Show results

The Show results window allows displaying and saving results without connecting inputs or tracks to the plug-in analyzers in advance.


Results to be displayed are selected as follows:

1. Select the plug-in which calculates the results,

Usersmanual 38.png


2. select the results’ familly between:

  • Main is for results imediatelly provided by the analysis like the trigger blocks, RPM, spectra, FRFs, …
  • Profile is for scalar profiles like order tracking, acoustic level, RPM profiles, …
  • Waterfall is for 3D results.

3. Select the result type,

4. select the Inputs/Tracks to be displayed. This list gathers the sources in groups according to their physical quantities. One can develop the group for partial selection.

Go. Use the Show button to display your selection. This button operates in 2 ways:

  • Add a new window in the current layout with the selected results by clicking the button
  • Drag & Drop the button to an existing window of the current layout to add the selected results in this window.
References

Cross functions (FRFs, ORFs, Coherence, etc..) are selected through the bottom right area. The references are displayed as the inputs/tracks using the physical quantity group. There is no need to predefine the cross function from the Plug-in settings.

Orders and overall
Usersmanual 04.png

For order tracking, the Show results window features a fast and simple order selection mode. While selecting order-based result, one can enter the chosen orders in the bottom right area of the window.

Values are entered directly using the keyboard; The Enter and up/down keys will navigate to next or previous lines in the list.

If the plug-in channels show different orders to track for one line, "Mixed" will be displayed.

Save results

Results to be saved (i.e. added to the save selection list) are selected as for showing it.

There are 3 ways to save the results:

  • Manually by using the save button. This will add the selected results to the save selection.
Usersmanual 113.png

Automatically and continuously, by checking the Save displayed results check box at the bottom of the window. This will continuously add the displayed results to the save selection. Results remain in the save selection list, even if they are removed from the layout.

Usersmanual 27.png

Automatically once by using Measurement\Save\Add All Results button from the ribbon. This button acts like the save all display result but only at once.

  • This button is grayed when all displayed results are already in the save selection
  • When the Save displayed results is active, this button shows
Parameters

The bottom half of the window allows adjusting the selected plug-in parameters and triggering.

Usersmanual 114.png

1. This button opens the active plug-in properties. NB: it is also possible to access it from the ribbon while the window is open. Helpful with the directly available main settings.

2. Click here to open the Events connection window, where one can associate event with plug-ins’ Start, stop or trigger.

3. Activate the plug-in tach with this combo box. The tachometer properties will be proposed just after selecting the tach. The corresponding input (dynamic, or ext. synch) is automatically activated.
NB: The selected tachometer is associated with the plug-in. For profile and waterfall results, the corresponding tachometer is showed as: XXX tach (ex. FFT1 tach, or SOA2 tach)

4. Click on the engine tachometer icon to setup the delta RPM for scheduled analyses with Profiles and Waterfalls.

Step 3 Results overview
Call

Available from the bottom bar. This window shows a synthetic table of the displayed and saved results. Close the window by clicking on its control button closing the window (up-right red cross).

Usage

The table summarizes all the displayed and saved result (i.e. present in the Save Selection list), by:

  • Plug-ins
  • Type of results
  • Groups (i.e. Physical quantity)

The 2 columns at the right, indicate what is done with each set of results. Show for the displayed results and Save for the to-be-saved results.

Usersmanual 115.png

The check boxes have 3 possible status:

Usersmanual 116.png Checked, means all the inputs with these type and physical quantity, calculated by the plug-in are saved and/or displayed.

Usersmanual 117.png Unchecked, means none of the inputs with these type and physical quantity, calculated by the plug-in are saved and/or displayed.

Usersmanual 118.png Partial, means only a part of the inputs with these type and physical quantity, calculated by the plug-in are saved and/or displayed. One can check and uncheck the Save column boxes. Partial status boxes change to checked or unchecked only.

It is possible to check the results one by one with the Save Selection window by clicking on the corresponding button at the bottom-right of the window

Interface description

See interface overview page

Analyzer Settings

The Log Window shows all the changes made to the modules (Front-end, Filter builder, Monitor, FFT x, etc.) in the ASB.

Some setting values need to be adjusted when another setting value is modified. So when you change a setting value in the ASB (new value: ...) which may affect another setting value, the Log window marks the changes made by the analyzer (adjusted to: ...).

1. Right click on this area:

2. Select Copy (to paste a setup in a text document for example)

3. Clear the display in the Analyzer Settings tab.

Warning

The Warning tab shows any unauthorized operations you have carried out or errors reported by NVGate®.

1. Right click on this area:

2. Select Copy (to paste a setup in a text document for example)

3. Clear the display in the Warning tab.

Macro Trace

The Macro Trace tab shows the operations (the start and stop macro execution, errors) made in the macro mode.

Warnings do not stop macro execution but major errors will.

1. Right click on this area:

2. Clear the display in the Macro Trace tab.

Tip: double clicking on the error icon in the Macro Trace tab will open the Macro Editor on the failed command.

Workspace
Usersmanual 39.png

The workspace is a dockable tab on the left part of the NVGAte interface it holds 3 main themes of the analyzer interface.

Analyzer Setting Browser (ASB)

The analyzer is controlled through a tree of settings called the Analyzer Setting Browser (ASB). This tree consists of a set of modules that allows to setup the signal acquisition, play back and processes.

Note: The "information" icon Usersmanual 134.pngmay be found next to a setting. It means you cannot change the setting value.

Tip: When using the right click on any item from the ASB, you can copy the value(s) contained in the selection (it can be a module, collection, sub-module or just a setting) and paste it (them) into another item which contains compatible value(s). It is also possible to drag and drop a scalar type setting Usersmanual 135.pngfrom the ASB to a displayed window (for example the center frequency of the FFT Zoom).

Ways of editing a setting

Right click on an item and select Properties. You can check your setup and also change the settings in real time by double-clicking on the cell you want to change. The drop-down menu or the mouse wheel can also be used.

A setting can be set to its default value by right-clicking on it and by selecting Set to default.

Usersmanual 136.jpg
Analyzer states

In the analyzer Setting Browser, you can find the analyzer states icons. They were made to show you visually the state of each plug-in analyzer at the same time. Follow the icon descriptions:

Usersmanual 137.png The plug-in analyzer is stopped

Usersmanual 138.png The plug-in analyzer is running

Usersmanual 139.png The plug-in analyzer is paused

Usersmanual 140.png The plug-in analyzer is recording

Usersmanual 141.png The plug-in analyzer is waiting for a trigger: defined Event or Manual ( Usersmanual 142.png )

Usersmanual 143.png The plug-in analyzer is waiting for the user answer: Accept ( Usersmanual 144.png ) or Reject ( Usersmanual 145.png ) the signal

Usersmanual 146.png The plug-in analyzer is failed (the analyzer is not able to do the data acquisition anymore; a warning message will appear)

Modules

There are 4 types of modules:

Usersmanual 147.png The sources that acquire store and play back signals

Usersmanual 148.png The resources that provide events, filters, weighting windows, and tachometers to the plug-in analyzers

Usersmanual 149.png The plug-in analyzers that process independent analysis modes

Usersmanual 150.png The Waterfall that synchronizes the results computed by the plug-ins

The modules contain different functions located on sub-modules.

A collection Usersmanual 151.png is a box that contains a group of sub-modules of the same type (inputs, filters, channels, etc.). The sub-modules of collection can be active (visible) or inactive (hidden). Right click on it to add/remove channels.

The settings are inside the sub-modules. The ASB has a maximum depth of 3 levels: module, sub-module and setting. In the case of multiple similar sub-modules (inputs for example), the user sets his analyzer simply by changing the settings. The settings are grouped in families:

  • The scalar settings

Usersmanual 152.png are every numerical value which can be entered from the keyboard.

  • The label settings

Usersmanual 153.png are every character string which can be entered from the keyboard.

  • The enumerated settings

Usersmanual 154.png are a selection of an item from a list (items are character strings or numbers).

  • The Table setting is a group of values
  • The Matrix setting is selection of a matrix’s intersections
  • The Boolean setting

Usersmanual 155.png allows activating or deactivating functions (inputs, auto-calibration, zoom…)

Project Manager

The Project Manager is used to store all your projects, results and measurements…. There are several display options that enable you to show or hide certain items.

Tip: you can drag and drop any type of result from the Project Manager to the windows top to display the result window.

The Project Manager is made up of 3 main parts: the Workbook, the Project and the Measurement.

Workbook
Usersmanual 156.png
Project
Usersmanual 25.png
Usersmanual 157.png
Measurement
Usersmanual 158.png

In front of the projects and measurements item, 2 small icon may be present: e.g: Usersmanual 159.png

  • The icon Usersmanual 160.pngindicates if a project/measurement contains a signal file.
  • The icon Usersmanual 161.pngindicates if a project/measurement contains results.
Control panel

The configurable Workspace area provides quick access to settings and/or ASB status. It looks similar to the "Favorites" in Internet Explorer. The settings can be classified into customizable tabs.

Tip: a setting from the ASB can be added to the Control Panel by right clicking the setting in the ASB and select Add to Control Panel.

Usersmanual 162.png
Customization

The control panel is a part of the Workspace. It is used to control the measurement process. It is user-customizable and saved in the current project. Customization can be reached by right clicking on the Control Panel or from the Tools tab and Customize.

Usersmanual 163.png

Tip: Use drag and drop to add a setting from a place to another. The destination tab must be compatible with the setting you try to add to.

Displays

Different windows which contain one or several graphs or traces can be created. You can also add or remove some information in the Infotrace using the Infotrace properties. Manage all the display settings using the right click on almost any area. For each result type there are different available options using the right click.

Usersmanual 165.jpg
Multi-graphs windows

A graph is the area where traces are displayed. A multi-graph window contains several graphs which display signal from the same source or plug-in analyzer. The graphs can be displayed with different physical quantities.

Multi-traces

You can display several traces in the same graph. You can also display in multi-trace 3D mode.

Multi-traces display is not available for Waterfall displays.

The trace represents a signal or a result.

Cursors

The cursor is displayed when cursor mode is selected: Used to move the cursor by left clicking and dragging.

Select Usersmanual 166.pngfrom the Measurement tab in the Graphs group in order to activate the cursor mode.

Markers
Usersmanual 10.png

Select a type of marker from the Display/Graphs tab in the Markers group in order to activate the marker mode.

To add a marker on a graph, double click on the graph. Obtain information about a trace by using the marker table.

Scales

The scale displays the magnitude and the grid of the graph.

Infotrace

Displays information about the graph:

Graph mode: magnitude, real…

List of traces with their status: available or not/displayed in all areas or not/not displayed. You can move into the infotrace to select a specific trace and to follow cursor’s value of this trace. Memorized traces are also displayed in the list.

  • Overall levels: displays the RMS level in 2D windows containing spectra or time signals
  • Cursor information: x,y, order, dx, dy if available
  • Marker arrays

Using keyboard arrow up/down, you can select the active trace in the infotrace.

Contextual menus

Right click on the graph provides access to the scale, zooms and X/Z axis references of the current graph.

Usersmanual 167.jpg

Right click on the window to access the local windows properties and actions on the contained traces.

Usersmanual 168.jpg

Right click on the infotrace allows customization of the displayed information.

Usersmanual 169.jpg